OS X 10.10 Yosemite Compatibility Update

Apple OS X 10.10 Yosemite

For those Mac users who are curious about trying the latest version of the Mac OS, we've done a bit of testing with OSX 10.10 Yosemite.

While there are still quite a few rough edges, and many DAWs aren't completely stable, the current versions of all Exponential Audio plug-ins are running well. 

We should add that we've tested with LogicX, Nuendo 6 and ProTools 11.2.1, all 64 bit.

Please check with your DAW vendor before updating your machine.

For a compatible list of machines then visit Apple